Author Topic: Errors say many DLL files are missing (I have the Visual C++ Redistributables)  (Read 335 times)

swift master

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
I downloaded the Dim3 engine (version 24) and I placed the sample "Data" folder in the same directory as the executable files.

When I try to open "dim3 Engine.exe", I see an error for each of these missing DLL files:

1. glew32.dll
2. SDL2.dll
3. libmpg123.dll
4. JavaScriptCore.dll

When I try to open "dim3 Editor.exe", I see errors about these missing files:

1. glew32.dll
2. libpng15.dll

I read the "Important Read Me.txt" file about the required packages from Microsoft, but they're already installed on my computer. I tried again by opening the installers for those packages and pressing "Repair", but the same errors appear when I open dim3.

I am using Windows 10 Pro 64b.

What else should I do to be able to use this engine?

ggadwa

  • Administrator
  • Full Member
  • *****
  • Posts: 199
    • View Profile
    • Klink! Software
I just ran this on a windows 10 box and it seems to work.

You might need to have all those DLLs in the same directory as the dim3 application, that's the way I run it.  Are those DLLs in the directory with the dim3 Engine file?

[>] Brian